The Ecommerce Module has been fully restored. All services are operational. We apologize for the inconvenience.
Posted Apr 02, 2026 - 04:44 EDT
Update
The Ecommerce Module is currently unavailable due to a server rebuild. Our team is actively working on restoration and we expect it to be back online later today. We will post another update as we get closer to completion.
Posted Apr 01, 2026 - 10:09 EDT
Identified
Ecommerce module rebuild is in progress. Currently at ~58% completion. Estimated time to full restoration is approximately 6 hours from now (~4:00 PM ET). Processing rate has been variable — we will post another update as we get closer to completion.
Posted Apr 01, 2026 - 10:06 EDT
Investigating
The Ecommerce Module is currently down while it is being rebuilt. A time estimate for restoration will be provided around 9:00 AM ET. We apologize for the inconvenience.